Monthly Archives: January 2019

  • -

How to solve the problem that BMW ICOM A2 A3 host can’t be connected New

BMW-ICOM-A2+B+C

After the BMW ICOM host is connected to the car via a 16 PIN connector, and the other side is connected to the computer via a network cable. Your OBD2 Scanner BMW ICOM lan and system lights will light up. As follows:

But at this moment,the host can’t be found in the computer.As follows:

When meeting the problem,please update your
30% Discount Products BMW ICOM firmware as the following method:
1.Please connect BMW ICOM to the computer with network cable and power on the BMW ICOM with a 12V power adapter.
2.Open the website address http://169.254.92.38:60080/by IE browser, username:root password: NZY11502.
3.Click the “update firmware”,it will show ICOM firmware version information.
4.Choose the file ICOM-BootImage-01-11-01.bin,set image type to SYSTEM,click “Send the file”.
5.When shows “Write the image file to the flash?”,click “Yes”,then ICOM light turns red.
6.When shows “The SYSTEM IMAGE update was successful”,click “Update Firmware”.
7.Choose the file ICOM-ApplicationImage-01-15-01.bin,set image type to APPLICATION.Click “Send the file”.It will takes a few minutes because of a little large file.
8.When shows “Write the image file to the flash?”,click “Yes”,then the ICOM light turns red for the second time.
9.It is all normal,click “reboot”.


  • -

VCDS 18.9 Update for VAG Com Original VCDS 18.9.0 Register Interface

VCDS 18.9.0 updated, VAG-COM VCDS 18.9.0 version includes support for new 2019 model cars,as well as a number of other enhancements and improvements. VCDS 18.9 can update online directly for who have VCDS 18.2.1 VAG-COM Cable. VCDS 18.9.0 release works with VAG-COM from Obd2tool.com & all genuine Ross-Tech interfaces made since 2004, but support for 2019 model cars requires a current register interface.

VAG-COM-V18.9-VCDS-18.9-2 VAG-COM-V18.9-VCDS-18.9-3

VCDS 18.9 Software Overview:
Software Version: VCDS 18.9
Release VCDS 18.9 operating system: works with Windows 7, 8, and 10 (both 32-bit and 64-bit)
Earlier versions of Windows such as 2000, XP, and Vista might still work, but we no longer consider them supported.
VCDS does not work on “Windows 10 S”, which does not allow software to be installed from any source other than the Microsoft Store. If wish to use VCDS on a computer with this “Student” version of Windows, you’ll need to upgrade it to Windows 10 Pro.
Windows running in a VM (Parallels, Virtual Box, etc) may work but is not supported.
Windows 95, 98, ME, and NT4 definitely will not work.
VCDS Release 18.9 compatible hardware: must be used with a licensed Ross-Tech interface.
That include all genuine HEX-, KEY-, KII-, or Micro-CAN series Interface of interfaces.
It does not work with any third-party interfaces or some of the older “low-tech” interfaces we made and sold before 2004.

Need VCDS 18.9.0 VAG-COM VCDS 18.9 Ross-Tech Register Interface Ross-Tech VCDS genuine interface just contact us freely.