Unlock SD Connect C4 by PCB Modification

  • -

Unlock SD Connect C4 by PCB Modification

“If your Mercedes-Benz Star diagnosis SD Connect c4 is locked, do not need to buy a new set and just change this chip is ok.” said a Mercedes owner with MB SD C4 diagnostic tool.

Here is the customer solution to unlock MB Star diagnostic tool sdconnect c4 mux.

NOTE: AT RISK TO TRY!

PCB modification procedure:

1- Carefully open the sd connect multiplexer

2- Check whether some part is easy broken

MB SD Connect C4 printed circuit board in a good condition should be:

2016-sd-connect-compact-4-pcb-1

2016-sd-connect-compact-4-pcb-2 2016-sd-connect-compact-4-pcb-3 2016-sd-connect-compact-4-pcb-4 2016-sd-connect-compact-4-pcb-5

 

3- Possible occasion:

Maybe batteries leaked and damaged the PCB.
4- Blow the chip marked with a red circle by a electric hair drier

2016-sd-connect-compact-4-pcb-6

5- Disassemble the chip

6- Write the program to a new chip

7- Install the new chip to the PCB, then assemble PCBs into SD connect c4 mux

8- Start SD c4 mux

9- Connect MB SD C4 multiplexer to the laptop

10- SOLVED! And work like a charm, as a good SD Connect C4 at obd2tool.

If method above cannot help you out please contact OBD2TOOL customer service.

Hope this helps!


  • -

MB Star C3 09 2018 Xentry cannot work on W204

Mb Star C3 Star diagnostic system failed to work on Mercedes W204? Here is the customer solution. You are at your risk!

Problem:

I have DELL D630 with Xentry 09/2015 and MB Star C3 multiplexer. I have connected many cars (W202, W203, W210, W211, W245, etc) and there is no problem with connection – everything is working like a charm. Some days ago, I have bought W204 C280 from 2007. After I choose model, engine and transmission, and I go to diagnostic I see this:

“The diagnosis application is being started…”

mb-star-c3-w204-1
and few seconds later this:

“Initialization of the multiplexer has failed”

mb-star-c3-w204-2
My Mux is not compatible with W204? I searched few hours without success.

Customer solution:
W204 and X204 is the last Mercedes models which working without some special modifications.
You can try:

First try in toolkit.ini delete line skipcomports=all and set line usecomport=2 then you will see in SDconnect toolkit PartD on display after mux connection.

First save your original file for sure.

Try look into C:\Userdata\Config\Xentry\driver – slave.ini and set there com port which you have used for PartD.

Report:

There was no change because I didn’t restarted system. After restart work perfect.

Your solution work perfectly! Probem solved. Everything is working like a charm.

Obd2tool.com solution:

If you need to deal with newer Mercedes models, better go for SD Connect C4 or Xentry C5 diagnostic system.